|
filemon – Performance statistics for files, logical/physical volumes and virtual memory segments.
Examples | What it does |
filemon -o /tmp/filemon.log -O all | Monitor activity at all file system levels and write the results to the file named /tmp/filemon.log |
trcstop | The trcstop command will terminate the trace initiated by the filemon command. |
fileplace – Reports the placement of a file’s blocks within a file system.
Used to examine and assess the efficiency of a file’s placement on disk.
Example:
fileplace -pv /unix
netpmon
Performance statistics for CPU usage, network device-driver I/O, socket calls, and NFS I/O. For CPU usage, it estimates how much of this usage is due to network-related activities.
Example:
- netpmon -o /tmp/netpmon.log -O all
- trcstopThe trcstop command will terminate the trace initiated by the netpmon command.
lsps – Report statistics about paging space.
Example: lsps -a
iostat – Report statistics for ttys, disks and cpu
Examples | What it does |
iostat -d hdisk0 hdisk1 5 | Will monitor disk activity only for physical volumes hdisk0 1 |
iostat -t 5 | Will monitor terminal activity only and display tty statistics every 5 seconds |
ipcs – Status of interprocess communication facilities.
This is a kernel attribute that cannot be modified.
lsattr – Lists attributes associated with a device.
NOTE: maxmbuf sets the limit of the memory governed by the IPC and network buffering capability.
Examples | What it does |
lsattr -l sys0 -E | Entries marked ‘True’ are attributes that can be configured |
lsattr -l sys0 -a maxpout=9 -a minpout=6 | Changes the HIGH/LOW water marks for pending write I/Os per file. |
nfsstat – Display information about NFS and RPC calls
Examples | What it does |
nfsstat | Displays statistics about NFS and RPC calls |
nfsstat -zcsr | Initializes statistics (to ZERO) for client (-c), server (-s), and rpc (-r) calls. |
pagesize – Display system page size
ps – Display status of current processes.
This command is useful for determining if runaway processes are excessively utilizing the CPU or memory.
For example, if a machine was just rebooted and appears to be running slowly, use this command to see if there are any getty processes running wild, using excessive CPU time.
- Getty’s should never be using more than 0% of measured CPU time as reported by the output of the command ps avg.
- If this is not the case, suspect noise on that line.
- A login state of PDELAY for that port may resolve that problem.
- STAT column
- R means RUNNING process
- S means SLEEPING process
- Z means ZOMBIE process
- RSS represents how much memory (in 1k bytes) process is using.
- SIZE represents how much paging space (in 1k bytes) process is using.
- CPU represents how much cpu time a process is using
- MEM represents a percentage of remaining memory a process is using
Examples | What it does |
ps avg | a displays information about all processes v displays fields: PGIN,SIZE,RSS,LIM,TSIZE,TRS,%CPU,%MEM |
ps -ft tty2/0 | Lists all the processes running on port tty2/0 |
ps -furoger | Lists all the processes running under the user roger |
ps -e | Display the environment as well as the command |
ps -ef | Full listing of all processes in the system. If the ‘C’ field (means processor utilization) has a large value, this means that that process is a CPU intensive task. |
ps -t – | Lists processes not associated with a terminal |
pstat – Statistics about system attributes.
This utility is useful to determine how much paging is in use. If the amount of paging space is less than the amount of real memory in the system, it’s possible the system will run out of paging space before real memory. This is because AIX performs early allocation of page space. When a page is referenced, real memory and paging
space blocks are allocated. If there are less paging space blocks then real memory pages, paging space will be exhaused before all of real memory is consumed.
Examples | What it does |
pstat -s | Displays paging space statistics |
pstat -T | Displays system variables |
sar
System Activity Recorder utility found on all UNIX systems that monitors various system functions like
- cpu
- hard disk
- terminal IO
- number of files open
- processes running
Use cron to execute sar at specific times based on workload, and the sa1 and sa2 scripts to maintain a report history of system usage.
Examples | What it does |
nohup sar -A -o /tmp/SAR.STATS 60 600 > /dev/null & | Collect all the statistics that sar monitors at 60 second intervals for a 10 hour period. Also redirects console output to null device |
sar -u 5 10 | Interactively run the sar command and review CPU utlization every 10 seconds for 5 interations. |
svmon
Virtual memory monitor that captures a snapshot of the current contents of both real and virtual memory, and summarizes the contents. Useful for determining which processes are using the most memory.
tprof – Detailed profile of CPU usage by an application.
Provides an estimate of CPU usage for each routine in a profile. Useful to determine where an application maybe CPU bound.
vmstat – Statistics about virtual memory and cpu/hard disk usage.
Example: vmstat hdisk0 hdisk1 5 (Display various statistics every 5 seconds)