Installation Commands
|
mksysb – System backup before updates
Whenever an update to the system is attempted
- Always make sure that a smit mksysb backup of the system was made. If something goes wrong during the update process you will have the ability to restore the system back to it’s previous state. If not followed, MURPHY’S LAW could come into play.
- When applying an update, bring the system down to maintenance mode using the command shutdown -Fm. This way you are absolutely sure that no one else can effect the update process.
- Make sure the following three file systems are mounted: /, /tmp, and /usr. If /tmp or /usr are unmounted, re-mount them since they will be needed during the update process.
- If the system was preloaded (there are installable images under the /usr/sys/preload directory), make sure you:
- Backup those images to a tape for later reference (Optional)
- Remove the /usr/sys/preload directory and its contents.
- Once those images are installed, no need to keep them lying around
lssrc -a
The command lssrc -a will list all src controlled installed subsystems. If you only want to list active subsystems, use the command lssrc -a |grep active.
If you are going to update a subsystem that is currently active, you need to de-activate each of the subsystem(s) using one of the following commands:
- stopsrc -g <SubSystem Group>
- stopsrc -s <SubSystem Name>
Some subsystems (eg., DOS SERVER) may have to manually be brought down with the kill command. If these steps aren’t taken, the lpp may fail to install.
bffcreate
Examples | What it does |
bffcreate -qv -d/dev/rmt1.1 -X pci sna snamEn_US | extracts the pci, sna, and snamEn_US backup images from the tape device and places them under the /usr/sys/inst.images directory (default for install images) for future installation. |
bffcreate -qv -d/dev/rmt0.1 -X all | extracts all the images on the tape to /usr/sys/inst.images. |
instupdt
Install, reject, and/or update licensed program products (lpps).
Examples | What it does |
instupdt -r | Rejects applied updates that have yet to be committed. Use this command if one or more lpps failed to install properly. You may have to manually change the stat of the OPP rom broken to installed. If a second go around fails, use the next 2 commands. |
lslpp -l | Determines if the state of the lpp is something other than ‘installed’. |
odme lpp | Use this command to correct If the state is not installed. Do not use this command without first consulting an AIX system engineer. |
instupdt -qI -d/dev/rmt0.1 -v -X -F bosadt.xde.obj bosadt.xde.obj | Installs the bosadt.xde.obj lpp from the tape device. If the lpp already exists, the ‘-F’ option will force an install of a lower version of an lpp over a higher version (overwrite option). |
instupdt -qI -d/dev/rmt0.1 -v -X bosnet.tcpip.obj | Installs the lpp image named bosnet.tcpip.obj for the first time.-q=quiet mode (suppresses prompt for device)
-I=install -X=expand file system if necessary to install lpp -v=verify installed files for correct checksums |
instupdt -acq -d/dev/rmt0.1 -v -X bosnet.tcpip.obj | Installs original release of bosnet.tcpip.obj and then applies the newest update for that lpp.-ac=apply and committ |
smit instupdt_list_problems | Lists the problems fixed in this current release. |
instupdt -qU -dev/rmt0.1 -ac -X bosnet.tcpip.obj | Updates lpp named bosnet.tcpip.obj with newest release. Must have an installed image in order to apply an update. In other words, you can’t apply an update to an image that doesn’t exist on your system. |
installp
Examples | What it does |
installp -C | Used to cleanup after a failed lpp install/update |
installp -c -g -X all | Commits all applied LPPs or PTFs |
installp -q -d/dev/rmt1.1 -l > /tmp/toc.list | Lists the table of contents for the install/update media and saves it into a file named /tmp/toc.list |
installp -s | Lists the lpps that have been applied but not yet committed or rejected. |
xlpp
Examples | What it does |
xlpp -f /dev/rmt0 -lv > /tmp/TableOfContents | Generates a numbered list of available images on tape device /dev/rmt0. |
xlpp -vf/dev/rmt0 -I <directory> <TapeNumber> | Extracts one image at a time. Specify the number of the image TapeNumber rather than the name of the image. Also specify the directory where the image will reside. TapeNumber is the number of the image file as listed in the /tmp/TableOfContents file generated in the above step. |
ifregs
Examples | What it does |
ifreqs > /tmp/ifreqs.list | |
installp -f /tmp/ifreqs.list | Produces a list of PTFs that need to be applied/committed. |
lppchk
Determines if any files belonging to the specified lpp are corrupt and if so will set the lpp to broken.
Examples | What it does |
lppchk -c bosext2.dosutil.obj | Verifies file checksum and length for the dosutil.obj, against the checksum/file length settings stated in the /etc/security/sysck.cfg file. |
lppchk -v | Displays information about missing PTFs or information about the incorrect state of a PTF. |
lppchk -f bos.obj | Verifies that the files belonging to the specified LPP exist and are of the correct file size. |
lslpp
Show attributes of license program products installed
Examples | What it does |
lslpp -A | Generates the fixes for particular U numbers |
lslpp -l | List of license program products installed |
lslpp -h | Shows history (version level) of license program products |
lslpp -f bosext2.dosutil.obj | List of files that belong to the license program product selected |
lslpp -p x_st_mgr.obj | List of prerequisites objects that need to be updated with x_st_mgr |
lslpp -acl|egrep APPLIED | List of LPPs installed but not committed. Whenever an update is done, make sure you first check to see if that object that is to be updated has pre-requisites. If it does, make sure these objects (xxxxx.obj) get updated, too. |
lslpp -v | Verifies the LPPs installed were installed correctly. sysck used to verify contents of files at install/update time. |
Once the lpp image is applied, the sysck utility will consult the config file named /etc/security/sysck.cfg to verify file length and checksums. If no problems are encountered, the image will be committed and marked installed else is set to broken.
PowerChute configuration
The rs/6000 normally has two serial ports that can be used to connect the cable from the UPS device: tty0 or tty1. You need the correct cable from APC.
You need to disable the tty port. This can done in smit. You can also use the command pdisable tty0 or tty1.
- Enter smit
- Select Devices
- Select TTY
- Select Change/Show characteristics
- Select the correct tty, either tty0 or tty1
- Change the baud rate to 2400
Depending on the APC model, you need to set the value for clocal in the Stty attributes for runtime and login.
clocal must be in the list of attributes if you are using an APC model
- Smart-UPS
- Matrix-UPS
- Advanced port of Share-UPS
- SmartSlot Expansion Chassis port
- Pass-through port of PowerNet SNMP Adapter
clocal must NOT be in the the list of attributes if you are using an APC model
- Back-UPS
- Pack-UPS Pro
- Network PowerCell
- Basic port of Share-UPS
- SmartSlot Interface Expander port