SCSI device numbering
During installation, hard disk numbering is based on the SCSI address of the PV (hdisk?), as well as the SCSI controller slot number.
- On the RS/6000 model series 5×0, 7×0, and 9×0, AIX starts checking at microchannel slot #8 and works it’s way up to slot #1.
- For the model 3×0 series, hdisk numbering starts from slot #1 and works it’s way down to slot #4.
- Do not have more than 3 SCSI devices configured for each SCSI controller for performance reasons.
bootlist
<td “>Attempts to boot over the network first, then from any SCSI attached device(s)
Examples |
What it does |
bootlist -m normal badisk scdisk |
Will look for any bootable bus attached disk first, then will look for any bootable SCSI disk last. |
bootlist -m normal en0 scdisk |
top of page
chdev
Change one or more attributes for a specific device configuration. If the chdev command doesn’t change the attribute in question, you may have to make the device DEFINED first. Change the device attribute by making the device AVAILABLE.
Examples |
What it does |
chdev -l tty22 -a login=delay -a speed=19200,9600,2400,1200 |
Changes the terminal port (tty22) to autobaud between the speeds of 19200 downto 1200. If your login attribute is set to delay (login=delay), a modem can also use this port for calling out or receiving incoming calls. May have to generate a BREAK sequence so getty process will downshift to the next speed when logging in from a modem so both sides are communicating at the same speed. One or more carriage returns must be entered at the keyboard BEFORE a login prompt is generated to the terminal screen.
A DELAY port will NOT generate a login prompt automatically like a ENABLE port will. |
rmdev -l tty22 |
Makes the device defined |
chdev -l tty1 -a logger=/usr/bin/mview |
Whenever the system is rebooted, the program /usr/bin/view will be executed on terminal tty1, so that when that terminal is turned on, that application will already be running. |
chdev -l scsi0 -a dbmw=0x902000 -P |
-P=permanent change. Must reboot for change to take effect. Changes the maximum transfer rate to/from scsi0 device to 8MB. Applies to ALL devices attached to this SCSI controller. Useful for speeding up backup procedures, since it allows writes of multi-megabyte record length to a tape device. |
chdev -l hdisk1 -a pv=yes |
Changes an available disk to a physical volume |
mkdev -c tape -t 8mm -s scsi -p scsi0 -w 30 |
Creates a new 8mm tape device using scsi controller ‘0’ with a scsi id of ’30’. |
chdev -l rmt0 -a ret=yes |
Instructs the tape drive to retension a tape automatically whenever a tape is inserted. Retensioning involves winding a tape to the end and then rewinding back to the beginning. Helps reduce tape errors by evening the tension throughout the tape. Default is no |
chdev -l rmt0 -a density_set_1=17 -a density_set_2=16 |
Sets the preferred density value to the HIGHEST density possible on that tape drive, while density_set_2 sets the next highest density setting on the tape drive. |
chdev -l rmt0 -a compress=yes |
If the drive is capable of compression, data written to the tape will NOT be compressed. Read operations aren’t affected by the setting of this attribute. |
top of page
cfgmgr
Automatically configures devices that have been just added or not powered on since the system was last rebooted.
top of page
format, fdformat
The format command formats a diskette for high density (default)
The fdformat command formats a diskette for low density (default).
The format command determines the device type, which is one of the following:
(Sector size is 512 bytes for all diskette types.)
Type |
Floppy Size |
Tracks |
Sectors |
360K |
5.25-inch low-density |
40×2 |
9 |
720K |
3.5-inch low-density |
80×2 |
9 |
1.2MB |
5.25-inch high-capacity |
80×2 |
15 |
2.88MB |
3.5-inch high-capacity |
80×2 |
36 |
Examples |
What it does |
format -d /dev/rfd0 |
Format a diskette residing in the /dev/rfd0 device for high density |
format -l -d /dev/fd1 |
Format a 360K-byte diskette in a 5.25-inch, 1.2M-byte floppy drive |
format -d /dev/fd0 |
Format a 720K-byte diskette in a 3.5-inch, 1.4M-byte floppy drive
A 360K-byte diskette drive may not be able to read a 360K diskette that has been formatted in a 1.2M-byte drive. |
format -d /dev/fd0.9 |
Format a 720KB diskette |
format -d /dev/fd0.18 |
Format a 1.44MG diskette |
format -d /dev/fd0.36 |
Format a 2.88MG diskette |
fdformat -h |
Force high-density formatting of a diskette |
top of page
lsattr – List attributes for a specific device.
Options |
What it does |
-E |
Current |
-a |
Attribute name |
-l |
Class names: tty, printer, tape, disk, adapter, dlc, bus, diskette, if, memory, logical_volume, mouse, port ` |
Examples |
What it does |
lsattr -l rmt0 -E |
Lists current attributes for tape drive mode. |
lsattr -l tty0 -a speed -R |
-R=range of baud rates. List valid ranges for speed attribute for a tty device |
lsattr -l scsi0 -E |
Display current attributes about scsi0 device |
lsattr -l cxma0 -E |
Display the characteristics of a defined 128-port async adapter |
top of page
lscfg – List all devices currently connected to the system
Examples |
What it does |
lscfg |
Partial listing |
lscfg -v |
Lists hardware and firmware levels for each device – if applicable |
lscfg -l ent0 -v |
Lists hardware and firmware levels for ent0 (ethernet) device |
top of page
lsdev – List device attributes
Options |
What it does |
-E |
Current |
-a |
Attribute name |
-l |
Class names: tty, printer, tape, disk, adapter, dlc, bus, diskette, if, memory, logical_volume, mouse, port |
Examples |
What it does |
lsdev -C |
Lists all those devices that are currently configured (-C) since the system was either LAST rebooted OR the smit cfgmgr command was run. |
lsdev -C|grep rmt |
Displays attributes for the ‘rmt’ (magnetic tape) devices only |
lsdev -P -H |
Displays different attributes from PREDEFINED database |
top of page
mkdev – Adds a device to the system.
This command can also be used to change the STATE of a device. Devices NOT turned on when the system is rebooted will only be DEFINED to the system. To access those physical devices, they MUST be in an AVAILABLE state.
Examples |
What it does |
mkdev -l tty1 |
Assumming the device state is DEFINED, will bring that device to an AVAILABLE state. A device that is DEFINED means the system knows that the device exists BUT has not been made it available for use. |
mkdev -l rmt0 |
If the power to the tape device was NOT turned on when the system was last rebooted, this device will be in a DEFINED state. To make this device available for use, execute this command. |
mkdev -ctty -ttty -srs232 -psa2 -w11 -alogin=enable -aterm=ibm3151 |
Creates a new terminal device on port 11 on adapter sa2. sa2 could be either an 8,16, or 64 port adapter card. The port is configured as an ibm3151 CRT and will generate a login prompt when turned on. |
top of page
rmdev – Removes a device from the system
Examples |
What it does |
rmdev -l tty1 |
Assumming the device state is AVAILABLE, will bring that device to a DEFINED state. If this command fails with a ‘/etc/methods/ucfgtty’ error, chances are the getty process is still running on that port. Use the pdisable command to stop the getty from running. Then execute the rmdev command so the port in question can go to a DEFINED state. |
1) pdisable 1
2) rmdev -l tty1 -d |
-d=deletes the tty definition from the ODM database. In order to remove the terminal device tty1 from the system, you must first disable the tty, followed by removing all instances of that device by using the ‘-d’ option. If there is a getty running on the terminal port to be removed AND that getty is not disabled, the following message will appear on screen: Method error (/etc/methods/ucfgtty): 0514-062 Cannot perform the requested function because the specified device is busy |
top of page